minimize to tray zmena verzie

Fórum o e-mailovom klientovi Mozilla Thunderbird
Napísať odpoveď
kmetino
začiatočník
začiatočník
Príspevky: 2
Dátum registrácie: 7. Júna 2010, 11:34

minimize to tray zmena verzie

Príspevok od užívateľa kmetino » 7. Júna 2010, 12:01

Zdravím páni

Mám problém s týmto add-ons. MinimizeToTray Ide o to že som našiel verziu ktorú je treba upraviť podľa nainštalovanej verzie. Mám verziu 3.0.4 .
Stiahol som add-on rozbalil , našiel som súbor instal.rdf zmenil som v ňom verziu na správnu a zbalil späť do súboru .xpi Ale teraz mi to už TB neberie a vyhadzuje chybovú hlášku "Neplatný inštalačný balíček 207"

Neviete mi povedať kde by mohol byť zádrheľ?
Ďakujem

kmetino
začiatočník
začiatočník
Príspevky: 2
Dátum registrácie: 7. Júna 2010, 11:34

Re: minimize to tray zmena verzie

Príspevok od užívateľa kmetino » 7. Júna 2010, 12:18

Vyriešil som to nainštalovaním príslušnej verzie. Týmto prosím modov a "lock alebo delete" topic.

Ale aj tak by ma zaujímalo kde som robil chybu v tej "univerzálnej verzii"
V tomto zdrojáku som zmenil verziu na aktuálnu v premennej <MaxVersion> 2.0a na 3.0.4

Kód: Vybrať všetko

<?xml version="1.0" encoding="UTF-8"?>

<!--
This build was generated for branch "trunk"
-->

<RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
     xmlns:em="http://www.mozilla.org/2004/em-rdf#">

  <Description about="urn:mozilla:install-manifest">
    <em:id>{31513E58-F253-47ad-86DB-D5F21E905429}</em:id>
    <!-- major.minor.release.build
         (build is generated from my build script) -->
    <em:version>0.0.1.2006102615+</em:version>
    
    <!-- Target Application this extension can install into, 
         with minimum and maximum supported versions. --> 

    <em:targetApplication>
      <!-- Mozilla Firefox -->
      <Description>
        <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
        <em:minVersion>1.0</em:minVersion>
        <em:maxVersion>2.0.0.*</em:maxVersion>
      </Description>
    </em:targetApplication>

    <em:targetApplication>
      <!-- Mozilla Thunderbird -->
      <Description>
        <em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
        <em:minVersion>1.0+</em:minVersion>
        <em:maxVersion>2.0a1</em:maxVersion>
      </Description>
    </em:targetApplication>

<!--Mozilla kind of stopped at 1.8, so we won't support it -->

    <!-- we do not support nvu on trunk -->

    <em:targetApplication>
      <!-- Sunbird -->
      <Description>
        <em:id>{718e30fb-e89b-41dd-9da7-e25a45638b28}</em:id>
        <em:minVersion>0.2</em:minVersion>
        <em:maxVersion>0.3</em:maxVersion>
      </Description>
    </em:targetApplication>

    <em:targetApplication>
      <!-- Seamonkey -->
      <Description>
        <em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>
        <em:minVersion>1.0</em:minVersion>
        <em:maxVersion>1.0</em:maxVersion>
      </Description>
    </em:targetApplication>
    
    <!-- Front End MetaData -->
    <em:name>MinimizeToTray</em:name>
    <em:description>Minimizes Mozilla windows into the system tray</em:description>
    <em:creator>Mook</em:creator>
    <em:contributor>helix400</em:contributor>    
    <em:homepageURL>http://minimizetotray.mozdev.org/</em:homepageURL>
    <em:optionsURL>chrome://minimizetotray/content/prefs.xul</em:optionsURL>

    <!-- Front End Integration Hooks (used by Extension Manager)-->
    <!-- 
    <em:iconURL>chrome://minimizetotray/skin/minimizetotray.png</em:iconURL> 
    -->
    
    <!-- Packages, Skins and Locales that this extension registers -->
    <em:file>
      <Description about="urn:mozilla:extension:file:minimizetotray.jar">
        <em:package>content/minimizetotray/</em:package>
        <em:locale>locale/en-US/minimizetotray/</em:locale>
        <em:locale>locale/ca-AD/minimizetotray/</em:locale>
        <em:locale>locale/cs-CZ/minimizetotray/</em:locale>
        <em:locale>locale/da-DK/minimizetotray/</em:locale>
        <em:locale>locale/de-DE/minimizetotray/</em:locale>
        <em:locale>locale/es-ES/minimizetotray/</em:locale>
        <em:locale>locale/eu-ES/minimizetotray/</em:locale>
        <em:locale>locale/fi-FI/minimizetotray/</em:locale>
        <em:locale>locale/fr-FR/minimizetotray/</em:locale>
        <em:locale>locale/fy-NL/minimizetotray/</em:locale>
		<em:locale>locale/el-GR/minimizetotray/</em:locale>
        <em:locale>locale/hu-HU/minimizetotray/</em:locale>
        <em:locale>locale/ja-JP/minimizetotray/</em:locale>
        <em:locale>locale/it-IT/minimizetotray/</em:locale>
        <em:locale>locale/lt-LT/minimizetotray/</em:locale>
        <em:locale>locale/nb-NO/minimizetotray/</em:locale>
        <em:locale>locale/nl-NL/minimizetotray/</em:locale>
        <em:locale>locale/pl-PL/minimizetotray/</em:locale>
        <em:locale>locale/pt-BR/minimizetotray/</em:locale>
        <em:locale>locale/ru-RU/minimizetotray/</em:locale>
        <em:locale>locale/sl-SL/minimizetotray/</em:locale>
        <em:locale>locale/sk-SK/minimizetotray/</em:locale>
        <em:locale>locale/sv-SE/minimizetotray/</em:locale>
        <em:locale>locale/zh-CN/minimizetotray/</em:locale>
        <em:locale>locale/zh-TW/minimizetotray/</em:locale>
        
        <em:skin>skin/classic/minimizetotray/</em:skin>
      </Description>
    </em:file>
    
  </Description>      

</RDF>
Mazarik:Zmenil som quote na code.

Napísať odpoveď